设为首页收藏本站

自己的路

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 30715|回复: 42

[已解决] LuNamp 升级php版本,修复Multipart/form-data漏洞(含升级PHP5.4的方法)

[复制链接]
发表于 2015-6-5 08:53:24 | 显示全部楼层 |阅读模式
前提:
本文描述的环境为centos6.5 64位、LuManager 2.0.99,未做过其他修改
以升级至php 5.5.25版本为例(此版已修复Multipart/form-data漏洞)
php-5.5.25.tar.gz和zend-loader-php5.5-linux-x86_64.tar.gz可从各自官网下载后再上传至服务器
以root权限登录服务器后,定位在/root目录下(此处目录随意,以下操作目录进行相应变动)

1. 获取lunamp最新版
  1. wget http://down.zijidelu.org/LuNamp_last.tar.gz
复制代码

2. 解压lunamp最新版
  1. tar zxvf LuNamp_last.tar.gz
复制代码

3. 获取php-5.5.25.tar.gz至/root/LuNamp/soft,此处无需解压

4. 修改/root/LuNamp/code/php/php.sh
32行:soft_version="5.5.25";#填写版本号

若第六步执行过程中报make命令未找到的错误,可尝试修改本文件如下2行(根据自身服务器make命令所在目录修改),否则无需修改。
103行:/usr/local/make/bin/make ZEND_EXTRA_LIBS='-liconv';#/usr/local/${ext_soft_dir}make/bin/make ZEND_EXTRA_LIBS='-liconv';
105行:/usr/local/make/bin/make install;#/usr/local/${ext_soft_dir}make/bin/make install

5.进入php目录
  1. cd /root/LuNamp/code/php/
复制代码

6. 执行安装
  1. ./php.sh
复制代码


若安装过程中出现 “Sorry, I cannot run apxs” 错误解决方案:
修改 /usr/local/apache/bin/apxs文件第一行(类似这样的一行) :#!/usr/sbin/perl -w
修改为(根据自身服务器perl命令所在目录修改):
  1. #!/usr/bin/perl -w
复制代码

7.获取并解压zend-loader-php5.5-linux-x86_64.tar.gz,将解压后目录下的opcache.so、ZendGuardLoader.so 两个文件覆盖到/usr/local/Zend/ 目录下
8.修改/usr/local/php/lib/php.ini文件,找到[zend5.3.X]段。(此处版本号可改可不改),
zend_extension=/usr/local/Zend/ZendGuardLoader.so
下添加下面一行
  1. zend_extension=/usr/local/Zend/opcache.so
复制代码

9. 重启apache服务

关键:make命令位置正确、perl命令位置正确。




 楼主| 发表于 2015-6-5 08:56:27 | 显示全部楼层
本帖最后由 hackerpl1 于 2015-6-5 09:03 编辑

结果:单网站使用fastcgi或nginx时为5.2.17,使用apache非fastcgi模式时为5.5.25

点评

PHP运行环境 cgi-fcgi PHP/5.2.17p1 升级成功了,还是5.2  详情 回复 发表于 2015-11-1 22:30
发表于 2015-6-12 22:24:18 | 显示全部楼层
洞哥不是说2.0.99版本还不支持5.3以上的吗?我服务器也被D死过好几次了,非常想更新PHP,楼主更新以后一切正常吗?
 楼主| 发表于 2015-6-16 14:52:33 | 显示全部楼层
修改后除了php程序要做相关适配调整外,其他用到现在一切正常
修改的是虚拟主机使用的php版本,LuManage本身使用的环境没变。
发表于 2015-6-17 17:56:23 | 显示全部楼层
成功升级,虽然lumanager后台还是现实5.3,但是phpinfo显示已经成功了,测试了一下没有发现异常!大家可以放心升级,楼主的流程很详细,容易出现错误的几个地方也都标注了。
发表于 2015-6-27 13:45:17 | 显示全部楼层
5.2.17没有支持了。
按照楼主的方法,可以升级到 5.6.10
发表于 2015-6-27 23:11:55 | 显示全部楼层
当年为了解决perl的冲突,多装了一个perl
感谢楼主!

点评

快点升级啊  发表于 2016-2-29 15:51
发表于 2015-7-3 17:27:51 | 显示全部楼层
爱洞特漏 发表于 2015-6-27 23:11
当年为了解决perl的冲突,多装了一个perl
感谢楼主!

32位可以升级吗?
发表于 2015-7-5 12:16:26 | 显示全部楼层
坐等洞哥升级,听洞哥的话,尽量自己不折腾。
发表于 2015-7-5 17:35:29 | 显示全部楼层
本帖最后由 相识不离 于 2015-7-5 17:36 编辑

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------

Build complete.
Don't forget to run 'make test'.

Installing shared extensions:     /usr/local/php/lib/php/extensions/no-debug-non-zts-20090626/


  这样算是安装完成了吗?
发表于 2015-7-6 17:36:45 | 显示全部楼层
让路,水军来了
发表于 2015-7-8 12:33:30 | 显示全部楼层
不知道洞哥会不会升级,现在很多软件都是PHP5.3以上的了
发表于 2015-7-12 16:43:04 | 显示全部楼层
感谢楼主,开始试了两次没成功,发现原来楼主说的几处修改都是必须要弄的

第三遍出现了n多的过程,有一些报警信息, 经历了很长时间的配置,希望能成功
发表于 2015-7-12 16:50:22 | 显示全部楼层
成功了!PHP Version 5.5.27
发表于 2015-7-19 02:07:07 | 显示全部楼层
fastcgi模式 也升级一下吧     升级到5.5更好    php_fcgi.sh     
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|Archiver|自己的路 ( 湘ICP备12010460号-2  粤公网安备 44010502000377号

GMT+8, 2019-7-19 10:20 , Processed in 0.052811 second(s), 24 queries .

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表