设为首页收藏本站

自己的路

 找回密码
 立即注册

QQ登录

只需一步,快速开始

楼主: hackerpl1

[已解决] LuNamp 升级php版本,修复Multipart/form-data漏洞(含升级PHP5.4的方法)

[复制链接]
发表于 2015-7-19 15:57:25 | 显示全部楼层
我在修改/root/LuNamp/code/php/php.sh 时没有发现32行:soft_version="5.5.25";#填写版本号,这个文件里,全是注释
发表于 2015-7-19 15:58:41 | 显示全部楼层
有谁会弄啊,加下我的QQ:3589448
发表于 2015-7-19 18:09:34 | 显示全部楼层
LUM后台还是
PHP        FastCGI: 5.2.17
非FastCGI: 5.3.14
发表于 2015-7-24 14:22:38 | 显示全部楼层
你好,修改/root/LuNamp/code/php/php.sh
32行:soft_version="5.5.25";#填写版本号  这个文件全是注释
发表于 2015-7-26 20:54:16 | 显示全部楼层
Linux(CentOS)   2.6.32-358.6.1.el6.i686   32位
我系统是这个为什么我升级后还是php -5.3.14  管理模板首页查看
FastCGI: Zend Optimizer v3.3.3
非FastCGI: (这里什么都不显示了)

我下载的是php5.5.27
按照上面的要求我都修改了也不行呢...
 楼主| 发表于 2015-8-19 23:39:56 | 显示全部楼层
liloufan 发表于 2015-7-26 20:54
Linux(CentOS)   2.6.32-358.6.1.el6.i686   32位
我系统是这个为什么我升级后还是php -5.3.14  管理模板 ...

管理面板是不会变的,仍然是5.3
新建一个虚拟主机,上传一个探针,就能看到已经升级成功。如果探针没有显示5.5.27,那就是失败了
发表于 2015-8-21 20:23:47 | 显示全部楼层
hackerpl1 发表于 2015-8-19 23:39
管理面板是不会变的,仍然是5.3
新建一个虚拟主机,上传一个探针,就能看到已经升级成功。如果探针没有显 ...

不行的我都试过好多遍了,不论版本还是注意事项我都看了也尝试修改了都不行
发表于 2015-8-26 12:23:25 | 显示全部楼层
QQ图片20150826122041.png
请问这里安装成功了吗?后面都步骤都进行了。但探针还是5.3.14
发表于 2015-9-1 18:08:08 | 显示全部楼层
直接用LuNamp_last.tar.gz安装的
zijidelu_php_zend.png
发表于 2015-9-4 15:03:53 | 显示全部楼层

补充:Zend-loader的安装opcache.so可以不覆盖

本帖最后由 knowingzq 于 2015-9-5 02:00 编辑

zend-loader-php5.5-linux-x86_64.tar.gz  这个文件在哪里可以找到?

后来在官网找到了下载的地方。

http://www.zend.com/en/products/loader/downloads#Linux

可按图索骥

必须要提一下,5.5.25我没有装过,我装的是5.5.28。装上之后出现zend版本错误信息,大致就是PHP自带的ZendAPI是20121212,而Zend-loader的API是20090906之类。后来再试的时候发现,覆盖文件的时候不要覆盖opcache.so文件。其他操作照旧,包括php.ini文件里添加语句。就不会出现zend版本的错误信息了。
发表于 2015-9-4 16:41:54 | 显示全部楼层

补充:make的问题

本帖最后由 knowingzq 于 2015-9-5 01:59 编辑

安装过程出现下面的提示。这个应该怎么解决,求救求救。
make: *** No rule to make target `clean'.  Stop.

后来干脆卸载了lump,然后重装了LuManager之后,再同样方式升级PHP,make的问题就解决了。
虽然还会报错,但是安装后使用顺利。
发表于 2015-9-4 16:43:01 | 显示全部楼层
commando 发表于 2015-8-26 12:23
请问这里安装成功了吗?后面都步骤都进行了。但探针还是5.3.14

你的那个问题和我的一样,前面的提示里都有,make: *** No rule to make target `clean'.  Stop. 你后来解决了没有?
发表于 2015-9-7 00:41:54 | 显示全部楼层

php-5.5.29.tar.gz 下载
http://pan.baidu.com/s/1sjn7Gtf
zend-loader-php5.5-linux-x86_64.tar.gz  下载
http://pan.baidu.com/s/1eQJIfNc
发表于 2015-11-1 22:30:39 | 显示全部楼层
hackerpl1 发表于 2015-6-5 08:56
结果:单网站使用fastcgi或nginx时为5.2.17,使用apache非fastcgi模式时为5.5.25

PHP运行环境        cgi-fcgi PHP/5.2.17p1
升级成功了,还是5.2
发表于 2015-11-10 09:22:35 | 显示全部楼层
按文操作了,结果还是PHP5.2.17,搞了好几遍,结果一样没升级到5.5.25,郁闷,怎么回事
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|Archiver|自己的路 ( 湘ICP备12010460号-2  粤公网安备 44010502000377号

GMT+8, 2019-3-24 18:04 , Processed in 0.098091 second(s), 20 queries .

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表