设为首页收藏本站

自己的路

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 4074|回复: 4

[求助] 升级nginx 和tengine失败

[复制链接]
发表于 2014-6-15 18:12:34 | 显示全部楼层 |阅读模式
tengish.jpg

未命名.jpg




按照教程
  1. wget http://nginx.org/download/nginx-1.6.0.tar.gz
复制代码

放到/home/zijidelu_install/LuNamp/soft  下修改 LuNamp/code/nginx/nginx.sh 和LuNamp/code/tengine/tengine.sh 把 soft_version 改成要升级的版本后 执行 nginx.sh和tengine.sh,然后出现上面的错误提示 ,..洞主求助!!



 楼主| 发表于 2014-6-15 19:06:57 | 显示全部楼层
本帖最后由 unosky 于 2014-6-15 19:16 编辑

更新:缺少soft目录缺少 p c  re-8.10
  1. wget http://dl.大不留滴linux.cn:5180/soft/p c re-8.10.tar.gz  
复制代码
放到 soft目录
  1. tar -xvf pcre-8.10
复制代码
执行 ./nginx.sh
提示LN: CREATING SYMBOLIC LINK '/USR/LOCAL/LuNamp/other_cmd/*':file exists
 楼主| 发表于 2014-6-15 19:52:49 | 显示全部楼层
rm -rf /USR/LOCAL/LuNamp/other_cmd/* 后编译成功!!!但是 /USR/LOCAL/LuNamp/other_cmd/里面的原来的文件就都没了!  访问phpinfo 400 bad request
 楼主| 发表于 2014-6-15 23:29:57 | 显示全部楼层
本帖最后由 unosky 于 2014-6-15 23:39 编辑

总结: 建议在安装lu之前自行下载LuNamp_last.tar.gz
解压之后自行把soft里面的 然后下载最新的nginx 和tengine把
建议用nginx 1.4.7和tengine 2.0.3 因为tengine是基于nginx1.4.7的
然后修改code/nginx/nginx.sh 修改nginx的版本号和code/tengine/tengine.sh的版本号!。
code/nginx/底下也有一个tengine.sh 不用管他 应该是洞主在测试的时候留下的!

未标题-2.gif
未标题-1.gif
发表于 2017-2-1 15:58:44 | 显示全部楼层
unosky 发表于 2014-6-15 23:29
总结: 建议在安装lu之前自行下载LuNamp_last.tar.gz
解压之后自行把soft里面的 然后下载最新的nginx 和t ...

掌柜好像话没有说完啊,解压之后自行把soft里面的,,,后面是什么,很关键啊
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|Archiver|自己的路 ( 湘ICP备12010460号-2  粤公网安备 44010502000377号

GMT+8, 2019-3-23 11:24 , Processed in 0.040127 second(s), 23 queries .

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表