设为首页收藏本站

自己的路

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 14521|回复: 12

Linux网站环境安装包LuNamp2.6开源(GPL)发布,不再支持FreeBSD系统

[复制链接]
发表于 2012-8-16 09:43:27 | 显示全部楼层 |阅读模式
更新时间:20120824 02:48(修正了不能在debian上安装的bug)

LuNamp是网站环境的自动化安装包,傻瓜化一键安装,支持源码安装和rpm二进制安装(使用rpm安装PHP+MySQL环境只需要几分钟),是具有6年多历史的FAMP的后续版本。目前支持的系统有Debian/CentOS/REH/Ubuntu系列(包括KUbuntu, 深度linux, 雨林木风Linux等)
遗憾的提示:在此之前的版本都是支持FreeBSD系统的,但由于开发难度较大等原因,从本版本开始,暂时不再支持FreeBSD系统,希望各位用户谅解!

#----- LuNamp2.6包含的组件
PostgreSQL(数据库), Bind(智能DNS), Apache, MySQL, Nginx, Perl, PHP, pure-ftpd, Memcached, Eaccelerator, GD, Rsync, ZendOptimizer等软件组成的

#------------------ 与LuManager高度兼容
LuManager是LuNamp的网页管理软件,通过它可以在线管理Linux/Unix服务器,快速安装Discuz、Phpwind、ECShop、Dedecms、Xweibo、Iweibo、PHPCMS、ECMS等PHP+MySQL架构的软件,5秒内即可创建一个网站!使创建网站的门槛大大降低。官方网站:http://www.zijidelu.org/forum-6-1.html
演示网站:http://demo.zijidelu.org:8888,用户名:zijidelu,密码:zijidelu


#----- 遵循GPL开源协议发布
意味着任何人都可以在遵循GPL开源协议的前提下复制、更改和再发布,从今天开始,您也可以轻易发布自己的服务器一键安装包了!
GPL协议翻译版:http://www.zijidelu.org/thread-2940-1-1.html
GPL协议英文版:http://www.gnu.org/copyleft/gpl.html

#------------------ 包括全自动编译安装和半自动编译安装
全自动安装(即一键安装,执行LuNamp2.6目录下的./i.sh -y便可)包含Apache,选择半自动安装时(./i.sh,不加-y参数),可以选择是否安装Apache,即可以只安装Nginx(LNMP)。不管是全自动还是半自动安装,都比手动配置环境要快,并且不会遗漏相关配置(长时间不配置系统,往往丢三落四的)

#------------------ 升级组件异常方便
拿升级Nginx为例:解压LuNamp_last.tar.gz后,上传新的nginx源码包到LuNamp/soft目录,然后执行LuNamp/code/目录下的nginx.sh再加版本号便可以升级nginx(./nginx.sh "1.0.15" "-y")。其它软件,如MySQL,Apache等也可以用此方法升级!
升级MySQL:先下载mysql的tar.gz压缩包放到LuNamp/soft目录下,然后切换到LuNamp/code目录,再执行以下代码即可升级。其中的"版本号"用mysql的具体版本代替,如"5.1.63"
./mysql.sh "版本号" "-y"

#------------------ 安全性和稳定性强
LuNamp基于安全稳定的Linux系统,常见的windows病毒和木马对该类系统无任何作用

#------------------ 下载、安装和卸载
#--------- 下载:
下载网址:http://lunamp.googlecode.com/files/LuNamp_last.tar.gz
更多RPM二进制安装包请前往http://code.googlecode.com/查看

#--------- 安装LuNamp:
1. 解压LuNamp_last.tar.gz:tar -zxvf LuNamp_last.tar.gz
2. 进入LuNamp目录:cd LuNamp
3. 执行安装:./i.sh -y(如果需要选择安装,请使用./i.sh,不加-y参数)
4. 如果是选择半自动安装,则会跳出选项框,选择1,将全部安装,选择2即卸载,选择3,便不安装Apache(LNMP或FNMP)

#--------- 使用二进制包安装LuNamp:
1. 下载rpm二进制包:wget http://lunamp.googlecode.com/files/LuNamp_last.x86_64.reh6.rpm
注意:如果您的系统是centos5,并且是32位的系统,那么二进制包则是LuNamp_last.i386.reh5.rpm
2. 安装rpm包:rpm -ivh --nodeps --force LuNamp_last.x86_64.reh6.rpm
3. 如果您的系统不是精简过的,一般重启即可使用,如果是精简过的,请重启后安装一下环境包:
yum -y install gcc gcc-c++ bzip2 make vixie-cron flex ncurses-devel wget patch ntp libxml2 libxml2-devel libevent m4 autoconf zip unzip libjpeg libjpeg-devel gd gd-devel freetype freetype-devel libpng libpng-devel openssl openssl-devel file libtool libtool-libs gmp-devel pspell-devel parted zlib perl mod_perl-devel apr-util ftp readline-devel curl curl-devel openssh-clients


#--------- 卸载LuNamp:
1. 解压LuNamp_last.tar.gz:tar -zxvf LuNamp_last.tar.gz(如果已经解压了,则略过)
2. 进入LuNamp目录:cd LuNamp
3. 执行安装:执行./i.sh,然后选择2,即可卸载LuNamp

#------------------ 软件操作相关
* 关闭所有组件:lu-stop
* 启动所有组件:lu-start
* 重启所有组件:lu-restart

* 关闭MySQL:mysql-stop
* 启动MySQL:mysql-start
* 重启MySQL:mysql-restart

* 关闭Bind:bind-stop
* 启动Bind:bind-start
* 重启Bind:bind-restart

* 关闭Nginx:nginx-stop
* 启动Nginx:nginx-start
* 重启Nginx:nginx-restart

* 关闭apache:apache-stop
* 启动apache:apache-start
* 重启apache:apache-restart

* 关闭pureftpd:pureftpd-stop
* 启动pureftpd:pureftpd-start
* 重启pureftpd:pureftpd-restart

* 关闭所有组件:lu-stop
* 启动所有组件:lu-start
* 重启所有组件:lu-restart

* 计划任务脚本文件:/usr/local/LuNamp/cmd/crontab_cmd.sh


#------------------ LuNamp和LuManager的目录结构
/
|---- etc/
|-------- my.cnf #mysql配置文件
|-------- ipfw.conf #ipfw防火墙的配置文件(仅FreeBSD)
|---- home/
|-------- ftp #FTP目录(默认情况下,所有网站位于此目录下)
|-------- hosts_backup #网站备份目录
|-------- logs_backup #网站访问日志备份目录
|-------- lum_files #重要内容保护目录
|-------- mysql_data #mysql数据库目录
|-------- pgsql_data #pgsql数据库目录
|-------- mysqls_backup #mysql数据库备份目录
|-------- pgsqls_backup #pgsql数据库备份目录
|-------- files_backup #垃圾桶(被删除文件)
|-------- lum_safe_files #LUM重要文件存放目录
|---- usr/
|-------- local/
|------------ apache/
|-------------------- httpd.conf #apache配置文件
|-------------------- vhost.conf #apache虚拟主机配置文件
|------------ apache_LuManager/
|------------ bind/
|------------ freetype/
|------------ gd/
|------------ jpeg/
|------------ libiconv/
|------------ libmcrypt/
|------------ libpng/
|------------ LuManager/
|---------------- Conf/
|-------------------- htaccess_files/ #伪静态(重写规则)存放目录
|-------------------- config.php #LUM配置文件
|---------------- Tpl/
|-------------------- App/ #应用程序目录
|-------------------- User_1520/ #用户模板目录
|---------------- Runtime/ #LUM临时目录
|------------ LuNamp/
|---------------- cmd/ #LUN系统命令存放目录(该目录下的命名无需使用完整路径,如要重启nginx,直接执行nginx-restart便可)
|-------------------- apache_LuManager-reload #重载LUM后台面板
|-------------------- apache_LuManager-restart
|-------------------- apache_LuManager-start
|-------------------- apache_LuManager-stop
|--------
|-------------------- apache-reload #重启apache
|-------------------- apache-restart
|-------------------- apache-start
|-------------------- apache-stop
|--------
|-------------------- crontab_cmd.sh #计划任务脚本
|--------
|-------------------- lu-repair #修复LUN和LUM的文件权限
|-------------------- lu-restart #重启LUN各组件
|-------------------- lu-start
|-------------------- lu-stop
|
|-------------------- mysql_install_db.sh #初始化数据库(危险)
|-------------------- mysql-restart #重启mysql
|-------------------- mysql-start
|-------------------- mysql-stop
|
|-------------------- nginx-reload #重载nginx
|-------------------- nginx-restart #重启nginx
|-------------------- nginx-start #启动nginx
|-------------------- nginx-stop #关闭nginx
|
|-------------------- pgsql-reload #重载PostgreSQL
|-------------------- pgsql-restart #重启PostgreSQL
|-------------------- pgsql-start #启动PostgreSQL
|-------------------- pgsql-stop #关闭PostgreSQL
|
|-------------------- pureftpd-restart #重启pureftpd
|-------------------- pureftpd-start
|-------------------- pureftpd-stop
|
|-------------------- webserver-reload #重载web服务(包括nginx和apache,会自动判断LUM是否启用apache)
|-------------------- webserver-restart
|-------------------- webserver-start
|-------------------- webserver-stop
|---------------- pm/ #phpMyAdmin目录
|------------ make/
|------------ memcached/
|------------ mysql/
|------------ nginx/
|---------------- conf/
|-------------------- nginx.conf #nginx配置文件
|-------------------- vhost.conf #nginx虚拟主机配置文件
|------------ perl/
|------------ php/
|------------ php_fcgi/
|------------ php_LuManager/
|------------ pureftpd/
|------------ pgsql/
|------------ Zend/
|------------ Zend_LuManager/
|------------ LuManager/


#------------------ 相关介绍
官方网站:www.zijidelu.org
作者:爱洞特漏
与LuNamp相关的软件:LuManager(LuNamp的网页化管理工具), HttpOS(WEB操作系统,已经包含LuManager和LuNamp),FAMP


发表于 2012-8-16 10:08:56 | 显示全部楼层
嗯 大力支持下~
发表于 2012-8-16 10:10:57 | 显示全部楼层
CCTV前来祝贺
发表于 2012-8-16 10:13:01 | 显示全部楼层
我擦 啥啊没抢到www.jnzxw.net 路过支持 顶
发表于 2012-8-16 11:05:53 | 显示全部楼层
本帖最后由 sonyr 于 2012-8-16 11:06 编辑

下载地址 https://lunamp.googlecode.com/files/LuNamp_last.tar.gz
发表于 2012-8-16 11:18:32 | 显示全部楼层
LUM开源了吗?
发表于 2012-8-16 13:24:22 | 显示全部楼层
Php_fcgi 安装不成功!停止安装LuNamp2.6
Php_fcgi is not installed! Stop to install .

debian
发表于 2012-8-16 22:06:10 | 显示全部楼层
configure: error: libjpeg.(a|so) not found.
make: *** No targets specified and no makefile found.  Stop.

make: *** No rule to make target `install'.  Stop.
make: *** No rule to make target `install'.  Stop.
./php/php_fcgi.sh: 114: setenforce: not found
./php/php_fcgi.sh: 124: cannot create /usr/local/php_fcgi/lib/php.ini: y nonexistent
./php/php_fcgi.sh: 138: /root/zijidelu_install/LuNamp/code/php/./php/php_fcgi.sh: not found
/usr/local/php_fcgi/lib/php.ini 不存在,没安装成功!
发表于 2012-8-23 08:03:24 | 显示全部楼层
学习了  呵呵
发表于 2012-8-24 02:00:27 | 显示全部楼层
请教大家——以前安装如何升级到LuNamp2.6呢?我现在的LuManager是2.0.85,不知道LuNamp是多少版本
发表于 2012-10-9 13:16:31 | 显示全部楼层
LuNamp  怎么没有个具体各个组建的版本啊

比如mysql php都是什么版本 如何升级
发表于 2013-1-24 22:50:42 | 显示全部楼层
相当可惜啊,不支持FreeBSD
发表于 2013-6-5 23:24:08 | 显示全部楼层
希望能够继续支持freebsd系统。虽然我是菜鸟,但我还是喜欢能用上bsd的。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|Archiver|自己的路 ( 湘ICP备12010460号-2  粤公网安备 44010502000377号

GMT+8, 2019-1-22 13:28 , Processed in 0.066493 second(s), 27 queries .

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表