设为首页收藏本站

自己的路

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 27736|回复: 20

为已经安装好的环境增加PHP扩展(如mysqli, mysql_pdo等)

[复制链接]
发表于 2012-4-17 16:56:34 | 显示全部楼层 |阅读模式
LuNamp一共存在3个PHP,说明如下:
/usr/local/php,这是非fastcgi所用的php,如果使用了apache,并且使用了非fastcgi模块,需安装扩展
/usr/local/php_fcgi,这是fastcgi所用的php,如果使用了nginx,需安装扩展
/usr/local/php_LuManager,这是LuManager所用的php,不必安装扩展

1. 下载LuNamp_last.tar.gz(如果本地已经存在LuNamp/code/php/php_extension.sh文件,则无需下载。如果是FreeBSD系统,请用fetch代替wget ):
  1. wget http://down4.zijidelu.org/projects/zijidelu-lunamp/files/LuNamp2.2/LuNamp_last.tar.gz
复制代码

2. 解压LuNamp_last.tar.gz:tar -zxvf LuNamp_last.tar.gz

3. 进入LuNamp/code/php/目录:cd LuNamp/code/php/

4. 执行:./php_extension.sh "mysqli" "5.2.17" "/usr/local/php_fcgi"
参数解释:
第一个参数为扩展名称(解压php-5.2.17.tar.gz后,会有一个ext目录,里面包括了很多扩展,目录名即为扩展名,如pdo_mysql,xsl,bcmath等),此处为mysqli,请用半角双引号包围
第二个参数为PHP版本号,此处为5.2.17
第三个参数为PHP的路径,此处为/usr/local/php_fcgi。如果使用了apache,请同时将/usr/local/php安装上扩展(LUM中,一共有三个php目录:/usr/local/php, /usr/local/php_fcgi, /usr/local/php_LuManager)

5. 登陆LUM后台,更新网站


评分

1

查看全部评分

发表于 2012-4-17 17:02:04 | 显示全部楼层
本帖最后由 化繁为简 于 2012-4-17 23:17 编辑

顶起来,太多人需要了!

反馈:我按照这种方法进行安装测试,发现问题还是没有得到解决!
发表于 2012-4-17 17:02:15 | 显示全部楼层
沙发坐上!!!!!
发表于 2012-4-17 17:07:59 | 显示全部楼层
  这两天发现国歌实在好听哇
发表于 2012-4-17 17:10:03 | 显示全部楼层
  这两天发现国歌实在好听哇
发表于 2012-4-17 17:10:40 | 显示全部楼层
  这两天发现国歌实在好听哇
发表于 2012-4-17 17:11:34 | 显示全部楼层
  这两天发现国歌实在好听哇
发表于 2012-4-17 22:33:27 | 显示全部楼层
....。。刚好需要。。。。
发表于 2012-5-9 18:25:06 | 显示全部楼层
LuNamp 位于什么位置啊。。。
发表于 2012-5-9 19:46:34 | 显示全部楼层
木有解决。。。
发表于 2012-5-24 12:46:46 | 显示全部楼层
一定要顶起来啊!!!!好
发表于 2012-6-11 23:13:25 | 显示全部楼层
按照此方法执行了好几回,都不行~能否提供另外种方法?
发表于 2012-10-20 01:37:26 | 显示全部楼层
本帖最后由 xiaomu 于 2012-10-20 03:44 编辑

为啥老失败呢?
发表于 2012-10-20 03:43:24 | 显示全部楼层
安装pdo_mysql模块老不成功,不知道啥原因 帮分析下啥原因?

1 我的安装文件在 /root/zijidelu_install/下
2 在/root/zijidelu_install/LuNamp/code/php 目录下 运行 ./php_extension.sh "pdo_mysql" "5.2.17" "/usr/local/php_fcgi"   
./php_extension.sh "mysqli" "5.2.17" "/usr/local/php_fcgi"

3 Lum登陆后 网站管理->网站更新
4 系统管理中重启服务器

可再登陆Lum 后点击菜单上 phpMyAdmin 还是显示 mysqli扩展还是有问题 说明mysqli没成功
Zend框架程序 ERROR: The mysql driver is not currently installed 说明pdo_mysql没成功
phpinfo()函数显示pdo只有        sqlite, sqlite2
php-5.2.17压缩包展开后发现ext目录下有这些模块啊,是神马原因呢?
 楼主| 发表于 2012-10-20 08:41:58 | 显示全部楼层
xiaomu 发表于 2012-10-20 03:43
安装pdo_mysql模块老不成功,不知道啥原因 帮分析下啥原因?

1 我的安装文件在 /root/zijidelu_install/ ...

没有为/usr/local/php_LuManager安装模块,而后台即用了/usr/local/php_LuManager模块
不需要安装也可
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|Archiver|自己的路 ( 湘ICP备12010460号-2  粤公网安备 44010502000377号

GMT+8, 2019-3-24 18:01 , Processed in 0.045143 second(s), 27 queries .

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表