设为首页收藏本站

自己的路

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 9323|回复: 5

[程 序] FAMP3.0(2007-12-15更新)

[复制链接]
发表于 2008-5-18 15:22:15 | 显示全部楼层 |阅读模式
离上一个版本的推出时间差不多一年了,感谢朋友们对FAMP的支持,抱着兴趣完成了FAMP3.0,希望能给大家带去些许方便...

注:此版本不能用于freebsd7X

主要更新:
1、修复上一版本的BUG。
2、含pure-ftp,并且通过mysql实现用户认证;
3、实现虚拟主机的空间、上传与下载的速度等限制;
4、标注部分安装信息,应该是初学者学习的好资料;
5、本次提供i386版和AMD64位版,请选择下载安装;
6、以前的版本,更换源程序版本比较麻烦,现在更简单了;

感谢:
感谢一直支持本人继续制作本软件的朋友们;
感谢反馈bug的同仁们;
感谢某位同仁(不知道是哪一位?)提供的pureftpd_php_manager的汉化版,谢谢您的劳动与汗水;

安全提示:
请用phpmyadmin更改pureftpd数据库的密码,然后再更改/usr/local/pureftpd/pureftpd-mysql.conf中的密码(默认是“loveworking”),否则pure-ftpd连不上数据库的哦!再重启pureftpd(/pureftpd-restart)

换版本:
换mysql:用您的源码包代替famp中的源码即可(源码位于famp3.0/FAMP/mysql/下);
换php:用您的源码包代替famp中的源码包(源源码位于famp3.0/FAMP/php/下)后,安装famp。然后重装一次zend(现在的php版本为php5X,如果您换成php4X,则需要重装zend)。再把/usr/local/apache/conf/httpd.conf里的“LoadModule php5_module modules/libphp5.so”改成“LoadModule php4_module modules/libphp4.so”
换apache:用您的源码包代替famp中的源码即可(源码位于famp3.0/FAMP/apache/下);

管理相关:
启动Apache:/apache-start
关闭Apache:/apache-stop
重启Apache:/apache-restart

启动pureftpd:/pureftpd-start
关闭pureftpd:/pureftpd-stop
重启pureftpd:/pureftpd-restart

启动mysql:/mysql-start
关闭mysql:/mysql-stop(需要输入您的mysql密码)

默认网站目录:/home/wwwroot
默认ftp会员目录:/home/ftp
默认数据库文件存放地址:/local/usr/local/mysql/var

mysql数据库用户名:root 密码为空(安装完成后自己修改,请用phpmyadmin修改)

感言:
看源代码容易,做成自动化安装就难了。请大家多给些建议,少些打击,谢谢!

I386版下载

AMD版下载

献爱心:支持作者。作者支付宝帐号:goushop@qq.com

安装步骤:
用最小化模式安装FreeBSD,不装apache,mysql,php,zend,pureftpd,如果装了,请将其删除!
用root身份登陆
1、下载:fetch http://www.zijidelu.com/download/famp3.0-i386.tar

或:fetch http://www.zijidelu.com/download/famp3.0-amd.tar
(注:fetch 然后加网址,便可以下载套包了)
2、解压:tar xvf famp3.0-i386.tar(或famp3.0-amd.tar)
3、进入目录(cd famp3.0)

4、执行./install(或./installlarge——自已认为网站访问量比较大,就用这个吧!)

pure-ftpd用的是21端口,可以在安装完成后更改端口或删除别的ftpd程序

通过./installlarge安装的,请根据网站的访问情况,自己调节httpd.conf中的worker参数值
发表于 2008-5-21 15:55:24 | 显示全部楼层
很是奇怪。以前我使用过FAMP3.0,一点问题都没有。
但是前不久在一台新的FreeBSD6.2上(最小化安装)安装FAMP3.0后,Apache启动不了,提示找不到libphp5.so
希望能够得到解答。
 楼主| 发表于 2008-5-22 12:52:43 | 显示全部楼层
原帖由 ltokok 于 2008-5-21 15:55 发表
很是奇怪。以前我使用过FAMP3.0,一点问题都没有。
但是前不久在一台新的FreeBSD6.2上(最小化安装)安装FAMP3.0后,Apache启动不了,提示找不到libphp5.so
希望能够得到解答。

确定选的版本是对的么?
如果提示找不到libphp5.so,一般是php编译没成功
由于本人不是亲自操作,不能凭着这个信息判断是哪里出了问题,不好意思!
建议你装一下最新的famp4.0.1
发表于 2008-5-22 18:04:42 | 显示全部楼层
最新的famp4默认是不带Zend的,使用ZendOptimizer-3.3.3-freebsd6.0-i386.tar.gz安装完成后查看phpinfo是正常的。但是在安装某些应用时会报错,如LxShops_GBK_2.0
但是我曾经使用famp3的环境成功安装过LxShops_GBK_2.0。
 楼主| 发表于 2008-5-23 15:12:53 | 显示全部楼层
原帖由 ltokok 于 2008-5-22 18:04 发表
最新的famp4默认是不带Zend的,使用ZendOptimizer-3.3.3-freebsd6.0-i386.tar.gz安装完成后查看phpinfo是正常的。但是在安装某些应用时会报错,如LxShops_GBK_2.0
但是我曾经使用famp3的环境成功安装过LxShops_GBK_ ...

这的确是麻烦事,但已经有临时的解决办法:
http://www.zijidelu.com/thread-8-1-1.html
发表于 2008-12-11 13:37:49 | 显示全部楼层

回复 3# 爱洞特漏 的帖子

今天我也见到这样的问题,一看是安装版本下错了,下了amd,
现在再下一个386的,试试看
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|Archiver|自己的路 ( 湘ICP备12010460号-2  粤公网安备 44010502000377号

GMT+8, 2019-1-22 13:30 , Processed in 0.037927 second(s), 21 queries .

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表