设为首页收藏本站

自己的路

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 10518|回复: 5

[求助] 安装moodle时出现php扩展问题

[复制链接]
发表于 2010-5-25 07:15:09 | 显示全部楼层 |阅读模式
名称 信息 报表 状态
php_extension curl - 推荐安装/激活为了使用Moodle网络功能,需要安装Curl库。 检查 php_extension openssl - 推荐安装/激活要使用Moodle网络功能,强烈推荐安装OpenSSL库。
检查 php_extension xmlrpc - 推荐安装/激活安装可选的xmlrpc扩展对于Moodle网络功能有用。

是在freebsd8.0最小化安装+Famp5.1.0下安装moodle的,出现问题后我修改/usr/local/php/lib/php.ini,把这几个扩展打开,重启服务器时出现多处类似php warning:php startup:unable to load dynamic library './php_curl.dll -cannot open "./phpopenssl.dll "in unknown on line 0
下面还有./php_openssl.dll    ./php_xmlrpc.dll 等这样几处类似的错误提示,
不知道哪位大哥知道怎么解决,麻烦看看,谢谢谢谢!
另:发现php.ini中好象的其他扩展都是带;号的,这也行啊?--我是菜鸟,不好意思。
 楼主| 发表于 2010-5-27 08:33:12 | 显示全部楼层
要死啊,大家纯围观?没有愿意出手给个提示什么的?我很想上进的!拜托拜托!!
发表于 2010-9-24 18:29:03 | 显示全部楼层
我也想知道这个问题
发表于 2010-9-30 21:04:28 | 显示全部楼层
这么多人怎么也不知道回答下啊??
这是因为洞主的这个程序没有安装这些php扩展啊,你只是修改了下php.ini想让它支持这些扩展,但实际没有安装它们当然会出错了。
哥们我安装moodle时也出现了这个问题,问了洞主,洞主让我自己学习啊。真是郁闷!不知你解决了没?
发表于 2011-3-15 16:11:14 | 显示全部楼层
网上搜索一下php扩展安装
发表于 2013-9-22 09:10:44 | 显示全部楼层
同样的问题,到现在也没人解决呀,LU应该考虑解决这个问题吧。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|Archiver|自己的路 ( 湘ICP备12010460号-2  粤公网安备 44010502000377号

GMT+8, 2019-3-25 14:20 , Processed in 0.033600 second(s), 20 queries .

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表