设为首页收藏本站

自己的路

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 104879|回复: 53

LuManager 安装篇

[复制链接]
发表于 2011-6-26 12:52:47 | 显示全部楼层 |阅读模式
1. 安装系统:(对于已经安装好linux系统的可直接跳过看第二条)
最小化安装系统(最好是全新安装系统,VPS用户可跳过此步骤,也可以在VPS控制面板中重装系统。如果是实体机用户,我们建议您选择ZijideluOS)。
安装linux系统建议及相关教程:
系统下载:http://www.zijidelu.org/thread-1336-1-1.html
用最小化方式安装FreeBSD的图解教程
Debian最小化安装图文教程
CentOS 5.4 最小化安装视频教程
使用LuManager时的分区建议 *必看*
在VPS上安装LuManager的视频教程

2. 登陆系统执行安装LuManager:
用超级用户root登陆系统。如果是FreeBSD,请切换到/home目录(cd /home,如果没有/home目录,则切换到/usr目录)。
我们建议您用ssh工具并设置成UTF-8编码登陆服务器,因为那样可以看到中文提示。SSH工具用putty,设置UTF-8编码的方法见http://www.zijidelu.org/thread-1818-1-1.html
3. 下载zijidelu_install.sh安装脚本:wget http://down.zijidelu.org/zijidelu_install.sh(FreeBSD系统则用fetch代替wget)
如果您的服务噐(或VPS)可以连接外网,却不能下载zijidelu_install.sh,请修改/etc/resolv.conf文件,将第一行的“nameserver dns服务器的IP”修改为“nameserver 208.67.222.222”,然后再下载即可
4. 赋予zijidelu_install.sh可执行权限:chmod 750 zijidelu_install.sh(或者chmod u+x zijidelu_install.sh)
5. 安装:./zijidelu_install.sh -y(此为全自动安装,如需半自动安装,请不用-y参数,即:./zijidelu_install.sh
6. 选择下载点:China的为中国电信下载点(默认),USA为美国下载点。选择好后回车 mirrors.jpg
7. 选择您要安装的版本:选1为1.0.X,选2为1.1.X
lum_ver.jpg
如果是Redhat系列系统,会提示您是否用rpm包来快速安装LuNamp,建议时间比较紧或编译安装失败的用户选择rpm包进行安装
rpm.jpg
提示:
a. 在CentOS系统上编译mysql时,在mysql-test部分,等待的时间会比较长,请耐心等待。
b. 如果在安装过程中断网,请重新执行安装便可(已经安装的会跳过)

单独下载安装:
安装脚本网址:http://lunamp.googlecode.com/files/zijidelu_install.tar.gz
LuNamp网址:http://[url=http://down.zijidelu.org/zijidelu_install.tar.gz]lunamp.googlecode.com/files/LuNamp_last.tar.gz[/url]
LuManager网址:http://down.zijidelu.org/LuManager_last.tar.gz

1. 将zijidelu_install.tar.gz通过sftp上传至服务器
2. 用root用户登陆服务器
3. 解压:tar zxvf zijidelu_install.tar.gz
4. 解压zijidelu_install.tar.gz后有一个zijidelu_install目录,然后将LuNamp_last.tar.gz和LuManager_last.tar.gz放在zijidelu_install目录下
5. 切换目录:cd zijidelu_install
6. 执行./i.sh -y(或用./i.sh进行半自动安装),同样可以安装!
这种方法可将LuNamp和LuManager一起打包分发,也就是把zijidelu_install目录打包即可用于分发。

意外情况:
* 在某些VPS上可能会提供环境安装不成功,那么需要在执行zijidelu_install.sh前手动安装环境,方法如下:
Debian系统:apt-get install gcc g++ ssh make bzip2 flex vim bison libncurses5-dev patch ntpdate
Centos系统:yum install gcc gcc-c++ bzip2 make vixie-cron flex ncurses-devel wget patch ntp libxml2 libxml2-devel libevent m4 autoconf zip unzip gd freetype
如现提问一律按y


login.jpg
发表于 2011-6-27 15:17:37 | 显示全部楼层
安装好了。顶
发表于 2011-6-30 13:47:58 | 显示全部楼层
我装过但是没成功。还是直接安装centos在装好
发表于 2011-7-7 05:50:02 | 显示全部楼层
正在安装呢
发表于 2011-7-7 06:59:55 | 显示全部楼层
总耗时:69 分钟
Total runtime: 69 分钟
终于装好了
发表于 2011-9-16 16:41:40 | 显示全部楼层
我装两次了,为什么就是装不上????????
发表于 2011-11-28 20:36:23 | 显示全部楼层
我用zijidelu linux 1.0自动安装后无法访问http://服务器IP:8888,现在正在手动安装,目前进行到下载这一步,能否成功不知道呀!
发表于 2011-12-10 10:25:10 | 显示全部楼层
我还是不会安装。
发表于 2011-12-23 14:17:21 | 显示全部楼层
我装了后,还是进不去http://IP:8888
发表于 2011-12-30 09:29:40 | 显示全部楼层
好贴,双手赞成!
发表于 2012-1-14 01:39:43 | 显示全部楼层
很好,谢谢你啊,辛苦了~~
发表于 2012-1-16 16:35:39 | 显示全部楼层
本帖最后由 实话实说 于 2012-1-16 22:13 编辑

Ubuntu安装不好啊。
错误信息:
  1. Configuring extensions
  2. checking size of long... (cached) 4
  3. checking size of int... (cached) 4
  4. checking for int32_t... yes
  5. checking for uint32_t... yes
  6. checking for sys/types.h... (cached) yes
  7. checking for inttypes.h... (cached) yes
  8. checking for stdint.h... (cached) yes
  9. checking for string.h... (cached) yes
  10. checking for stdlib.h... (cached) yes
  11. checking for strtoll... yes
  12. checking for atoll... yes
  13. checking for strftime... (cached) yes
  14. checking which regex library to use... php
  15. checking whether to enable LIBXML support... yes
  16. checking libxml2 install dir... /usr/local
  17. checking for xml2-config path... /usr/local/bin/xml2-config
  18. checking whether libxml build works... yes
  19. checking for OpenSSL support... yes
  20. checking for Kerberos support... no
  21. checking for DSA_get_default_method in -lssl... no
  22. checking for X509_free in -lcrypto... yes
  23. checking for pkg-config... /usr/bin/pkg-config
  24. checking for PCRE library to use... bundled
  25. checking whether to enable the SQLite3 extension... yes
  26. checking bundled sqlite3 library... yes
  27. checking for ZLIB support... yes
  28. checking if the location of ZLIB install y is defined... no
  29. checking for gzgets in -lz... yes
  30. checking whether to enable bc style precision math functions... yes
  31. checking for BZip2 support... no
  32. checking whether to enable calendar conversion support... yes
  33. checking whether to enable ctype functions... yes
  34. checking for cURL support... yes
  35. checking if we should use cURL for url streams... yes
  36. checking for cURL in default path... not found
  37. configure: error: Please reinstall the libcurl distribution -
  38.     easy.h should be in <curl-dir>/include/curl/
  39. make: *** 没有指明目标并且找不到 makefile。 停止。
  40. ./php/php.sh: 98: cannot create /usr/local/php/lib/php.ini: y nonexistent
  41. error: /usr/local/php/lib/php.ini not exists
  42. error: /usr/local/php/lib/php.ini 不存在,没安装成功!

  43. Php 安装不成功!停止安装LuNamp2.1
  44. Php is not installed! Stop to install .



  45. LuNamp安装失败
  46. LuNamp was install failed

复制代码
发表于 2012-2-10 03:56:13 | 显示全部楼层
我在阿里云装了后,进不去http://IP:8888,请教该如何处理呢?
发表于 2012-2-26 14:36:02 | 显示全部楼层
安装后默认密码各是多少?
发表于 2012-3-5 17:03:31 | 显示全部楼层
我还是不会安装。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|Archiver|自己的路 ( 湘ICP备12010460号-2  粤公网安备 44010502000377号

GMT+8, 2019-6-16 07:55 , Processed in 0.068944 second(s), 29 queries .

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表